GKE | C2C Community
Solved

GKE

  • 17 November 2022
  • 10 replies
  • 68 views

Userlevel 2

Hello,

I am trying to create a cluster and deploy my application using GKE.

I already have a cluster in place and it's fully functional, but when I created another cluster and tried to create a deployment after success pods are not appearing in the workload dashboard. But using “kubectl get pods” shows the pods with ready status 0.

Any idea what is going wrong? 

icon

Best answer by yuval 17 November 2022, 22:58

View original

10 replies

Userlevel 7
Badge +15

@yuval , do you think you could perhaps help with @alihrk ‘s question?

 

@alihrk - in the meantime, welcome to C2C and I would like to ask you if you could be so kind as to present yourself in the C2C Lounge using this template, so that we all can get to know you a bit better? 😎

Userlevel 4
Badge +3

Hello @alihrk .

 

Can you check if you don’t have the cluster / namespace filter active on the workload screen and that you are in the right project?

 

You can add a screenshot if you want me to look at it.

Userlevel 2

Hello @alihrk .

 

Can you check if you don’t have the cluster / namespace filter active on the workload screen and that you are in the right project?

 

You can add a screenshot if you want me to look at it.

Hello @yuval, I am in the right project but the cluster does not even show up in the filter. Check screenshots below.

 

when I connect to the cluster and type “kubens” cmd the namespaces that I created are appearing.

 

And here the result when I run “kubectl get pods”

 

Hope that will give you more insights.

Userlevel 4
Badge +3

Hello @alihrk .  Do you want to have a Google Meet session to show me your setup?

 

I would also try to use a private / incognito browser window and try signing in again to test browser issues. If not, it might be permissions but debugging together will probably be easier.

Userlevel 2

Hello @alihrk .  Do you want to have a Google Meet session to show me your setup?

 

I would also try to use a private / incognito browser window and try signing in again to test browser issues. If not, it might be permissions but debugging together will probably be easier.

Hello @yuval , I have tried incognito mode on chrome and tried safari both of them did not showed the new cluster or its’ pods in workload dashboard. 

And I would like to have session with you that would be very helpful.

Userlevel 4
Badge +3

@alihrk please email me (yuval@doit-intl.com) some options. I am in US pacific time zone.

Userlevel 2

Yesterday I figured out what was the issue on the dashboard.

I think it's a bug in the UI in the workload dashboard, the new cluster that I've created only appeared in the filter of the workload page when I clicked reset filter and discarded the changes.

 

Now both cluster appear the new and old one.

 

Userlevel 7
Badge +15

Thanks for letting everyone know, @alihrk . In the meantime, did you talk with @yuval ?

Also, would you like to let us know how helpful was @yuval and your overall experience with our community platform? 

 

Thanks in advance! 😎

Userlevel 2

@yuval was very generous to offer his help, but I was able to solve by myself this time.

But I f I was blocked by anything else, I will definitely  contact @yuval and ask for his help.

Thank you for your help, great community btw. ✌

 

 

Userlevel 7
Badge +15

Glad you enjoy it, @alihrk . Hope to see you posting regularly 😎

Reply